Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 13, 2025 - 18:00 CET
Scheduled
Dear customers,
As part of our ongoing commitment to delivering best-in-class services to our valued customers worldwide, we will be performing a major upgrade to our CGNAT infrastructure in Singapore.
During this maintenance activity, data sessions for certain devices may be temporarily closed and automatically re-established. This process is designed to be seamless and should not impact your devices.
Please be assured that we will closely monitor service availability throughout and following the maintenance window.
Important Notice: This upgrade will result in changes to the public IP pools. If you have specific firewall rules configured to allow traffic, we recommend contacting BICS for further details and guidance.
In the unlikely event that you experience any irregularities, please do not hesitate to reach out to our support team at customer.care@bics.com.
Posted Nov 06, 2025 - 18:01 CET
This scheduled maintenance affected: Data Connectivity.