Data service degradation in Kuwait networks

Incident Report for BICS - SIM for Things

Identified

Dear customers,
kindly note that data traffic in Kuwait is still blocked. We will notify you immediately once we receive any further updates.
Posted Mar 10, 2026 - 08:15 CET

Update

We have received confirmation from local operators by phone call that data service has been blocked for all international roaming SIMs because of government instruction. And there is no further information about when the block will be removed.
We will follow up with local operators.
Posted Mar 09, 2026 - 09:12 CET

Investigating

We have detected a data service degradation in all Kuwait 4G networks since 22:00 UTC. Currently, network attach is rejected by the local 4G operator networks. Data service is available only in Kuwait 2G networks.

We are requesting local operators to investigate the issue.
Posted Mar 09, 2026 - 08:53 CET
This incident affects: Data Connectivity and Roaming Destinations.