Uganda data services temporary suspension.

Incident Report for BICS - SIM for Things

Resolved

This incident has been resolved.
Posted Jan 19, 2026 - 08:38 CET

Update

Dear customers,
according to our monitoring and statistic traffic from Uganda restored. We are waiting for the official confirmation and continue monitoring.
Posted Jan 19, 2026 - 08:37 CET

Update

We are continuing to monitor for any further issues.
Posted Jan 13, 2026 - 18:00 CET

Monitoring

Dear Customers,
Please be informed that, according to the Uganda Communications Commission, data services in Uganda have been temporarily suspended due to election-related procedures.
Unfortunately, BICS has no influence over this situation.
We will keep you updated as soon as new information becomes available.
Posted Jan 13, 2026 - 18:00 CET
This incident affected: Data Connectivity.