Data and SMS service suspended in Russia

Incident Report for BICS - SIM for Things

Monitoring

Dear Customer,

Due to a decision of the Russian State authority, on the grounds of State and public security, SMS and Data roaming services on mobile networks in Russia are activated with a 24-hour delay after initial network registration.
BICS does not have any control nor influence over this delayed service activation.

If you have any questions or need further information, please feel free to reach out to your account manager.
Posted Oct 17, 2025 - 16:04 CEST

Update

Dear Customer,
We see SMS and Data roaming traffic resuming in Russia after the service interruption on 5th October due to a decision of the Russian State authority, on the grounds of State and public security.
We have yet to receive a confirmation from Russian operators that the SMS and data roaming services have been fully restored.
If you have any questions or need further information, please feel free to reach out to your account manager.
Thank you for your cooperation
Posted Oct 16, 2025 - 17:49 CEST

Identified

Dear Customer,

Russian operators have temporarily suspended Data and SMS service in Russia for inbound roaming due to a decision of the Russian State authority, on the grounds of State and public security.
BICS does not have any control nor influence over this decision and has no other choice than to notify you of said suspension.

Please rest assured that BICS is closely monitoring the situation and will work to re-establish the traffic as soon as permitted to do so by the Russian operators.
We understand the inconvenience this may cause and appreciate your understanding and patience during this time.
If you have any questions or need further information, please feel free to reach out to your account manager.

Thank you for your cooperation
Posted Oct 10, 2025 - 14:27 CEST
This incident affects: Roaming Destinations.